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Part 26: Contact-Analysis of a Glass-Balustrade and
a Laminated Glass Plate

Part 1: Contact-Analysis of a Glass-Balustrade

The glass balustrade assembly consists of a glass-plate, aluminium-bracket and
steel-uprofil. What displacements and stresses are there when the left side is loaded
with 1000 N. The bracket is clamped fixed in the uprofil. The uprofil is not
calculated because there are low stresses.

Glass-Plate
consists of 45 864 tedrahedral elements and 10 804 nodes are generated with
NETGEN with E-Modulus = 75 000 N/mmm² and Poisson-Zahl = 0.17

Aluminium-Bracket
consists of 44 928 tedrahedral elements and 10 354 nodes are generated with
NETGEN with E-Modulus = 71 000 N/mmm² and Poisson-Zahl = 0.34
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FEM-Merge
Select register „Files“ and menu „FEM-Merge“ in order to combine both structures to
one FEM mesh with 90 792 tetrahedral elements, 21 158 nodes and 2 element
groups.
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Create Load Case 1

The glass balustrade is loaded with 1000 N on the left side.

At first create a Surface Model with Register „View“ and the icon

Select register „Edit FEM-Project“ and „Point Load“ and create a Point Load with
Value of Load = 1 in x direction in order to select Surface 14 on the left side.
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Select „Editor“ and multiply the load values with the Load Factor 2.82 which is
calculated with 1000 N / 355.
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Create Load Case 2 with a Master-Surface Load
Load case 2 is the Master-Surface-Load for contact between plate and bracket.
Select register „Edit FEM-Project“ and „Surface Load“ to create a surface load
„vertical to Surface“ with the Surfaces 3 and 6, the load value is zero because it is
not used.
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Create Load Case 3 with a Slave-Surface Load
Load case 3 is the Slave-Surface-Load for second contact between plate and
bracket. Before the next step you must hide Element Group 2 with menu „Element
Groups“ so that only show the bracket part.

Select register „Edit FEM-Project“ and „Surface Load“ to create a surface load
„vertical to Surface“ with the 9 bracket contact surfaces (see below in black).
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Boundary Conditions

The Bracket is clamped fixed in the uprofil. Select register „Edit FEM-Project“ and
„Boundary Conditions“ and clamped fixed the 6 surfaces of the bracket.
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Material Datas

Select register „Edit FEM-Project“, „Material Datas“ and „Material Data-Base“ to
enter the material datas for the Glass-Plate with E-Modulus = 75000 N/mm² and
Poisson-Value = 0.17 and for the Aluminium-Bracket with E-Modulus = 71 000
N/mm² and Poisson-Value= 0.34.
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Contact-Analysis

Select register „FEM-Analysis“ and „Contact-Analysis“ to calculate the displacments
and stresses with the Quick-Solver.

The Contact-Analysis needs about 15 iteration for the calculation. The runtime for
the linear TET4 elements is 2 minutes and for the more precise quadratical TET10
elements is about 30 minutes.
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Postprocessing

Select register „Postprocessing“ and the icon to evaluate the displacements
and stresses.

Max. Displacements in x-direction = 74 mm (exactly 77 mm)
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Max. v.Mises-Stress of the Glass-Plate = 88 N/mm² (exactly 83 N/mm²)

Max. Tensile-Stress of the Alu-Bracket = + 57 N/mm²
Min. Compressive Stress of the Alu-Bracket = -71 N/mm²
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Part 2: Linear Statics-Analysis of a laminated Glass Plate

The previous glass plate 1333 mm x 400 mm x 15.33 mm is now calculated as
laminated glass with a three-layer glass structure and the following material data:

Glass Pane 1: Thickness = 6 mm Modulus of Elasticity = 75000 N/mm² P = 0.17

PVB Film: Thickness = 3.33 mm Modulus of Elasticity = 3 N/mm² P = 0.498

Glass Pane 2: Thickness = 6 mm Modulus of Elasticity = 75000 N/mm² P = 0.17

Create Layer 1 with 3D Mesh Generator GMSH
Glass pane 1 with the dimensions 1333 mm x 400 mm x 6 mm is first entered in the
CAD system and saved as a STEP file. In MEANS V12, select the “File” tab and the
“New” menu and select “3D mesh generator GMSH (STEP).
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Like NETGEN, GMSH is a very powerful STEP tetrahedron mesh generator that is
very easy to use. Select menu "3D" to first generate a moderate tetrahedral mesh of
256 elements and 112 nodes, whereby the upper and lower mesh density should be
the same.

Refine by splitting

The mesh refinement will only be carried out later in MEANS V12. In GMSH,
however, the “Refine by splitting” menu can also be used to mesh 8 times more
finely.
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Export in INP Abaqus format

Select the menu “File” and “Export” as well as “Mesh - Abaqus INP (* .inp)” and
export the INP file with the same name so that it is automatically loaded and
displayed in MEANS V12.

The glass pane is automatically displayed in MEANS V12 and has a Z depth of
0 mm to 6 mm.
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Smooth the mesh

So that the FEM mesh can be clamped from 1250 mm to 1333 mm, create the
following Range of Nodes with a Coordinate Range from X = 1150 to X = 1300 and

replace all X values of the Range of Nodes with 1250 mm with “Coordinate Factor”.
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The mesh can later be clamped exactly from 1250 mm to 1333 mm. Save this
model under the name “Layer_1.fem”.

Create Layer 2
To move the PVB film to the center, select the "View" tab and

"Node Modus" and "Coordinate-Factor" and add 6 mm in the Z direction. Then
select the “FEM analysis” tab and “Model Dimensions” to check the new Z depth of
6 mm to 12 mm.
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Move Range of Nodes

The nodes of the upper surface must be subtracted from 12 mm to 9.33 mm. To do
this, create a Coordinate range of 11.8 mm to 12 mm in Node Modus.

Then select the Coordinate-Factor and add the value -2.67 mm in the Z direction to
get the value 9.33 mm. With the “Model Dimensions” menu, the input must be
checked again. Save the FEM-Mesh with "Layer_2.fem".
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Create Layer 3

Load the first model "Layer_1.fem" again and add all Z values with a Coordinate-
Factor of 9.33 mm. Save the mesh with a Z depth of 9.33 mm to 15.33 mm as
"Layer_3.fem".

Merge Layers together
Load the first mesh "Layer_1.fem" again with the "File" tab and load the mesh
"Layer_2.fem" and "Layer_3.fem" one after the other with the "FEM-Merge" menu,
so that a main mesh with 3 layers is created.
Select the “Edit FEM Project” tab and “Element Groups” to display the mesh made
up of 3 element groups.
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Node-Check

Carry out a Check Node Numbering with the snap radius "3.2" in the register "Mesh
Generation" in order to delete all double nodes. The structure now consists of 768
tetrahedral elements and 226 nodes.

Refinement

Finally, select "Mesh Generation" tab and menu „Local Refinement“ and
twice the menu "FEM Mesh 8x finer" to get the laminated glass pane with 49 152
tetrahedral elements, 9541 nodes and 3 element groups.
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Create Load Case 1
The panel is loaded with 1000 N on the left side. First the surface model must be
created with the "View" tab. Then select the “Edit FEM Project” tab and “Point Load”
and generate a Point Load in the Z direction with the load value = 1 N by clicking on
the left Surface 4.

Select "Editor" and multiply the load value by the load factor 5.92, which can be
calculated from 1000 N / 169.
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Clamped fixed
The laminated glass plate is fixed clamped from 1250 mm to 1333 mm. Select the
“Edit FEM Project” tab, “Boundary Conditions” and “Define Coordinate Range” to
fixed clamp the plate.

Finally, the input of the material datas of the 3 element groups and the Statics-
Analysis with the Quick-Solver follow as already described in Part 1.
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Results

This is followed by a comparison of the results between a monolithic glass pane and
the 3-layer laminated glass plate with 2 glass panes and a PVB film.

Max. Z-Displacements monolithic Glass Plate = -72.23 mm (exactly = 72 mm)

Max. Z-Displacements with a 3-layer laminated Glass Plate = -311.67 mm
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Max. v.Mises-Stress = 85.2 N/mm² with a monolithic Glass Plate

Max. v.Mises-Stress = 222 N/mm² with a 3-layer laminated Glass Plate

Laminated Glass Effect

The linear statics analysis is only valid up to the yield point of glass - therefore
unfortunately it cannot be taken into account that after the break the glass splinters
stick to the film and thus increase the load-bearing behavior again. Research into
this effect is currently being carried out on car windshields in particular.
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Part 3: Calculate glass plate with table legs
The tetrahedron glass plate mesh from Chapter 26 is connected to a mesh with 4
pentahedron aluminum table legs.

The node imprint of the table legs at Z = 0 must be inserted into the glass plate
mesh so that the glass plate and table legs have the same node structures.
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Step 1: Create a Range of Nodes

Load the table legs mesh and select the “View” tab and the “Node-Modus” menu
and “Surface Nodes” to create a range of nodes for surfaces 3, 5, 7 and 13 at Z = 0.

Step 2: Create a new Add-List

Select the “Mesh Generation” tab and “Local Refinement” as well as the “Create an
additional Point-List“ menu and save the range of nodes under “tab14.Node”.
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Step 3: Create the node list of the Glass plate

Reload the glass plate mesh and select menu "Local Refinement" and
"Step 1: Create a new Point-List and Surface List of the actual FEM-Mesh“
to save the number of nodes and elements before inserting the add list.

Step 4: Insert the nodes from the .Node file

Then load the node list of the table legs with the menu "Load a Point-List from a
Node-File“ and check on the model whether the nodes are displayed correctly.

Step 5: Generate with Add-List

Now use the “Generate with the additional Point-List“ menu to call up the mesh
generator in order to insert the additional nodes of the table legs into the glass plate.

You get a new glass plate mesh with the knot imprint of the table legs

Step 6: Convert a pentahedral mesh into a tetrahedral mesh

If the table legs are made of extruded pentahedra, the pentahedron mesh must first
be converted into a tetrahedron mesh with register "Mesh Generation" and menu
„Quad Meshing / Refine ...“ and menu "HEX8 / PEN6 -> TET4" before loading.
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Step 7: FEM Merge

Then reload the the table legs mesh to the glass plate mesh with the register "File"
and "FEM Merge" and finally delete the overlaid nodes from the structure with the
register "Mesh generation" and the menu "Node Check".

The glass plate and aluminum table legs are now combined in one FEM mesh with
2 element groups.

Calculate CAD Assemblies

In this way, moderate CAD Assemblies with different Material Datas like E-Modulus
can be united together and calculated step by step.
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Postprocessing

Select register „Postprocessing“ to obtained the results when the glass plate is
loaded with 100 kg weight and the table legs are fixed clamped.

Maximal Displacements in Z-Direction = -7.17 mm

Maximal v.Mises-Stresses = 41 N/mm²
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Minimal Principal Stresses S3 = - 48 N/mm²

Maximal Shear-Stresses TAUxy = 9.3 N/mm²
Minimal Shear-Stresses Tauxy = - 11.25 N/mm²


